> -----Original Message----- > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > Sent: Tuesday, October 21, 2014 6:26 PM > To: Liu, Jijiang > Cc: dev at dpdk.org > Subject: Re: [dpdk-dev] [PATCH v6 1/9] librte_mbuf:the rte_mbuf structure > changes > > Hi Jijiang, > > 2014-10-21 16:46, Jijiang Liu: > > Remove the "reserved2" field and add the "packet_type" > > "Remove and add" can be said "Replace". > > > and the "inner_l2_l3_len" fields in the rte_mbuf structure. > > Please explain that you are using 2 bytes of the second cache line for TX > offloading of tunnels. > > > /* remaining bytes are set on RX when pulling packet from descriptor > */ > > MARKER rx_descriptor_fields1; > > - uint16_t reserved2; /**< Unused field. Required for padding */ > > + > > + /** > > + * Packet type, which is used to indicate ordinary L2 packet format > and > > + * also tunneled packet format such as IP in IP, IP in GRE, MAC in GRE > > + * and MAC in UDP. > > + */ > > + uint16_t packet_type; > > Why not name it "l2_type"?
In datasheet, this term is called packet type(s). Personally , I think packet type is more clear what meaning of this field is . ^_^ > -- > Thomas