> On 1 May 2019, at 23:15, Gilles Sadowski <gillese...@gmail.com> wrote:
>
> Hi.
>
>>> [...]
>>
>> So do we do:
>>
>> UniformRandomProvider restrict(JumpableUniformRandomProvider);
>> JumpableUniformRandomProvider restrict(LongJumpableUniformRandomProvider);
>> UniformRandomProvider restrict(RestorableUniformRandomProvider);
>>
>> Or:
>>
>> UniformRandomProvider unjumpable(JumpableUniformRandomProvider);
>> JumpableUniformRandomProvider
>> unlongJumpable(LongJumpableUniformRandomProvider);
>
> I'm a bit hesitant on the spelling…
Do you mean unlongJumpable vs unLongJumpable vs unlongjumpable? In that regard
I was maintaining the likeness to unrestorable, but since there are two words
after 'un' I put the second with camelcase.
Or just the entire method name? I don’t like it much but its function is clear:
allow access to jump() but not longJump().
>
>> UniformRandomProvider unrestorable(RestorableUniformRandomProvider);
>>
>> The later option only adds two new methods. The first has 3 new methods
>> (deprecating unrestorable with restrict) but suffers from having to cast
>> instances of multiple interfaces to ensure the correct restrict is called.
>
> Oops indeed.
> This is too error-prone.
>
>> So this makes me favour the verbosely named option.
>
> +1
>
> Regards,
> Gilles
>
>>
>> Alex
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
> For additional commands, e-mail: dev-h...@commons.apache.org
>
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org