Hi All: I find myself writing a lot of this kind of code:
if (SystemUtils.isJavaVersionAtLeast(JavaVersion.JAVA_1_8)) ... and Assume.assumeTrue(SystemUtils.isJavaVersionAtLeast(JavaVersion.JAVA_1_8)); I think this would be more tidy: if (SystemUtils.isJavaVersionAtLeast8()) ... If this makes your skin crawl, please present a (technical) argument against it... Gary