Right now, the ListFlights method returns a stream of FlightGetInfo (to be renamed FlightInfo). This actually turns out to be quite expensive in many cases since splits have to be generated. I'd like to propose changing this method to return a stream of FlightDescriptors instead. What do people think?
rpc ListFlights(Criteria) returns (stream FlightGetInfo) {} to rpc ListFlights(Criteria) returns (stream FlightDescriptor) {}