On Fri, May 22, 2015 at 11:46 AM, Randell Jesup <rjesup.n...@jesup.org> wrote:
> >As part of the effort to improve logging in gecko we'd like to introduce > a new set of unified log levels. > > >*PR_LOG_DEBUG + 1 aka log level 5* > > > >Various bits of code invented a log level that was less important than > >debug (I would call this verbose). This was not specified in NSPR logging, > >but just kind of worked. With the addition of |Info| we can transition > code > >that was using this pseudo log level to: > > - map PR_LOG_DEBUG => Info > > - map PR_LOG_DEBUG + 1 => Debug > > > >In this case we could have added a |Verbose| log level, but with the > >addition of |Info| and feeling that fewer is better we have decided > against > >that. > > This is used extensively in WebRTC and related media bits to enable > *huge* amounts of debugs (like every-frame debugs for audio or video or > per-network-packet debugs, which will swamp a system normally), and since > people are used to enabling "debug" on random modules (or all:5), having > verbose debugs in the "normal" :5 setting will cause pain. > > The above will also be surprising since it will work "differently" than > other modules, making the same sorts of debugs appear at different > levels. This would be expecially confusing to people not frequently > working in the module or when external users are asked to turn on > debugging. > > At minimum, I'd like to keep some form of Verbose (or VerboseDebug, or > what have you) to avoid this "surprise" factor. > +1 -Ekr _______________________________________________ dev-platform mailing list dev-platform@lists.mozilla.org https://lists.mozilla.org/listinfo/dev-platform