Am 23.09.26 um 11:50 schrieb Vincent Lefevre:
On 2026-09-22 15:33:05 +0200, Marco Moock wrote:
Am 22.09.26 um 05:30 schrieb Max Nikulin:
The issue is that nscd caches for an hour results with some IPv6
addresses and no IPv4 ones due to SERVFAIL in response to the A query.
As a result various tools can not connect the host due to lack of global
IPv6 routing.

Not an IPv6 issue and not an nscd issue.
If nscd caches the positive (e.g. answer with A/AAAA record) or negative
(server replies that the requested record does not exist) answer, it is
operation correctly. The failing DNS servers need to be handled at
libnss_dns.

Or perhaps nscd just misuses libnss_dns. Without documentation of
how nscd uses this library exactly, who knows?

The libraries are queried in order listed in nsswitch.conf. This can be tuned (continue after a successful query, retry options etc.) with some settings, see the nsswitch.conf manpage.

nscd is just a cache between the requesting application and the actual resolver libraries.

--
Gruß
Marco

Spam bitte an [email protected]

Reply via email to