Am 22.09.26 um 05:30 schrieb Max Nikulin:

The issue is that nscd caches for an hour results with some IPv6 addresses and no IPv4 ones due to SERVFAIL in response to the A query. As a result various tools can not connect the host due to lack of global IPv6 routing.

Not an IPv6 issue and not an nscd issue.
If nscd caches the positive (e.g. answer with A/AAAA record) or negative (server replies that the requested record does not exist) answer, it is operation correctly. The failing DNS servers need to be handled at libnss_dns.

You claim that it is not nscd failure. It is possible from my point of view. You blame a resolver plugin that is actually libnss_dns. My idea is that the trouble might be caused by plugin design, so plugins have no chance to do their job better. The latter case is in agreement that "it is not nscd's fault".

nscd is just the cache - I do not see why that is the issue here, especially in this buggy environment with uncooperative people unwilling to fix serious network issues.

--
Gruß
Marco

Spam bitte an [email protected]

Reply via email to