Ok, after looking at this, I've decided that the cracklib support for PAM would be best handled by having it in a seperate package. I want to propose a naming scheme for module packages for PAM similar to how apache modules are named, libpam-mod-foo, where foo is the module name. Using this scheme the cracklib PAM module package will be named libpam-mod-cracklib, and this package will contain the Depends for cracklib. source I have to 0.66, which will be in my first upload pending comments concerning this proposed naming scheme (i hope no one has any objections :)
I object to the the 'mod', it amounts to saying "Pluggable AUthentication Module module"[1]. You are using apache as an example, apache's modules are usually named 'mod_foo', so `libapache-mod-foo' is logical as a package name. I don't think that holds for PAM.
NOTE: This naming scheme will reuire the ppp-pam package to be renamed, any problems with this?
Uh why? `ppp-pam' is simply `ppp' with PAM support.
[1] Stamp out and eliminate redundancy! ;-) -- Joel Klecker (aka Espy) <URL:http://web.espy.org/> <URL:mailto:[EMAIL PROTECTED]> <URL:mailto:[EMAIL PROTECTED]> Debian GNU/Linux PowerPC -- <URL:http://www.debian.org/ports/powerpc/>