On Thu, 15 May 2025 15:37:39 GMT, fabioromano1 <d...@openjdk.org> wrote:
>> Some changes in `Biginteger`s' bit operations that increase the code >> readability and slightly optimize the execution time. > > fabioromano1 has updated the pull request incrementally with one additional > commit since the last revision: > > make magBitLength() an instance method src/java.base/share/classes/java/math/BigInteger.java line 3619: > 3617: int nzInts = numberOfTrailingZeroInts(); > 3618: if (nInts > nzInts || nInts == nzInts > 3619: && nBits > Integer.numberOfTrailingZeros(magLen - 1 > - nzInts)) { @rgiulietti The bug was there. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/25166#discussion_r2092889185