On Fri, 31 May 2024 16:15:12 GMT, Maurizio Cimadamore <mcimadam...@openjdk.org> 
wrote:

>> This PR restores a var handle cache in `Utils::makeSegmentViewVarHandle`. 
>> The cache was moved to `ValueLayouts::varHandle` as part of 
>> [pull/19251](https://git.openjdk.org/jdk/pull/19251), on the basis that we 
>> want to optimize the common case like:
>> 
>> 
>> ValueLayout layout = ...
>> layout.varHandle().get(...)
>> 
>> 
>> And that caching more complex var handles didn't seem to add value, given 
>> that, for these var handles, the logic in `LayoutPath` needs to adapt the 
>> returned var handle anyways.
>> 
>> But, `TestAccessModes` revealed a different picture - w/o any cache in 
>> `Utils` the test end up allocating 8963 var handle instances (instead of 
>> just 4), in each of the 4 runs the test includes. While this is admittedly a 
>> stress test, it seems nice to restore the level of sharing we had before 
>> [pull/19251](https://git.openjdk.org/jdk/pull/19251).
>
> Maurizio Cimadamore has updated the pull request incrementally with one 
> additional commit since the last revision:
> 
>   Address review comments

src/java.base/share/classes/jdk/internal/foreign/Utils.java line 106:

> 104:      * @return a raw memory segment var handle.
> 105:      */
> 106:     public static VarHandle makeRawSegmentViewVarHandle(ValueLayout 
> layout) {

Since I was here, I took the opportunity to rename this to include `raw`, to 
denote that the var handle returned by this method should not be exposed by 
APIs as is.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/19485#discussion_r1622666280

Reply via email to