> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the 
> number of compressed or uncompressed bytes read from the inflater is larger 
> than the Zip64 magic value.
> 
> While the ZIP format  mandates that the data descriptor `SHOULD be stored in 
> ZIP64 format (as 8 byte values) when a file's size exceeds 0xFFFFFFFF`, it 
> also states that `ZIP64 format MAY be used regardless of the size of a file`. 
> For such small entries, the above assumption does not hold.
> 
> This PR augments ZipInputStream.readEnd to also assume 8-byte sizes if the 
> ZipEntry includes a Zip64 extra information field. This brings ZipInputStream 
> into alignment with the APPNOTE format spec:
> 
> 
> When extracting, if the zip64 extended information extra 
> field is present for the file the compressed and 
> uncompressed sizes will be 8 byte values.
> 
> 
> While small Zip64 files with 8-byte data descriptors are not commonly found 
> in the wild, it is possible to create one using the Info-ZIP command line 
> `-fd` flag:
> 
> `echo hello | zip -fd > hello.zip`
> 
> The PR also adds a test verifying that such a small Zip64 file can be parsed 
> by ZipInputStream.

Eirik Bjorsnos has updated the pull request with a new target base due to a 
merge or a rebase. The pull request now contains 33 commits:

 - Merge branch 'master' into data-descriptor
 - Extract ZIP64_BLOCK_SIZE_OFFSET as a constant
 - A Zip64 extra field used in a LOC header must include both the uncompressed 
and compressed size fields, and does not include local header offset or disk 
start number fields. Conequently, a valid LOC Zip64 block must always be 16 
bytes long.
 - Document better the zip command and options used to generate the test vector 
ZIP
 - Fix spelling of "presence"
 - Add a @bug reference in the test
 - Use the term "block size" when referring to the size of a Zip64 extra field 
data block
 - Update comment reflect that a Zip64 extended field in a LOC header has only 
two valid block sizes
 - Convert test from testNG to JUnit
 - Fix the check that the size of an extra field block size must not grow past 
the total extra field length
 - ... and 23 more: https://git.openjdk.org/jdk/compare/e2042421...ddff130f

-------------

Changes: https://git.openjdk.org/jdk/pull/12524/files
 Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=12524&range=08
  Stats: 238 lines in 2 files changed: 237 ins; 0 del; 1 mod
  Patch: https://git.openjdk.org/jdk/pull/12524.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/12524/head:pull/12524

PR: https://git.openjdk.org/jdk/pull/12524

Reply via email to