On Thu, 16 Nov 2023 08:56:05 GMT, Andrey Turbanov <aturba...@openjdk.org> wrote:
>> A few classes in `sun.util` package have non-final fields which could easily >> be marked `final`. > > Andrey Turbanov has updated the pull request incrementally with one > additional commit since the last revision: > > 8316557: Make fields final in 'sun.util' package > > rename 'firstDay' to 'firstDays' to match 'minDays' naming Changes requested by naoto (Reviewer). src/java.base/share/classes/sun/util/cldr/CLDRCalendarDataProviderImpl.java line 48: > 46: public class CLDRCalendarDataProviderImpl extends > CalendarDataProviderImpl { > 47: > 48: private static final Map<String, Integer> firstDays = new > ConcurrentHashMap<>(); I don't think this is correct. "First Day" is the first day of the week and should not be plural. ------------- PR Review: https://git.openjdk.org/jdk/pull/15736#pullrequestreview-1734986993 PR Review Comment: https://git.openjdk.org/jdk/pull/15736#discussion_r1396065609