> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the 
> number of compressed or uncompressed bytes read from the inflater is larger 
> than the Zip64 magic value.
> 
> While the ZIP format  mandates that the data descriptor `SHOULD be stored in 
> ZIP64 format (as 8 byte values) when a file's size exceeds 0xFFFFFFFF`, it 
> also states that `ZIP64 format MAY be used regardless of the size of a file`. 
> For such small entries, the above assumption does not hold.
> 
> This PR augments ZipInputStream.readEnd to also assume 8-byte sizes if the 
> ZipEntry includes a Zip64 extra information field. This brings ZipInputStream 
> into alignment with the APPNOTE format spec:
> 
> 
> When extracting, if the zip64 extended information extra 
> field is present for the file the compressed and 
> uncompressed sizes will be 8 byte values.
> 
> 
> While small Zip64 files with 8-byte data descriptors are not commonly found 
> in the wild, it is possible to create one using the Info-ZIP command line 
> `-fd` flag:
> 
> `echo hello | zip -fd > hello.zip`
> 
> The PR also adds a test verifying that such a small Zip64 file can be parsed 
> by ZipInputStream.

Eirik Bjorsnos has updated the pull request with a new target base due to a 
merge or a rebase. The incremental webrev excludes the unrelated changes 
brought in by the merge/rebase. The pull request contains 21 additional commits 
since the last revision:

 - Remove excessive comment
 - Move isZip64ExtBlockSizeValid to ZipUtils, use it from ZipInputStream and 
ZipFile.Source
 - Merge branch 'master' into data-descriptor
 - Use block comments instead of javadoc comments to avoid doclint warnings
 - Merge branch 'master' into data-descriptor
 - Zip64 extra field of a LOC header has 1-3 long components
 - Clarify comment for shouldIgnoreExcessiveExtraSize
 - Update test to use a Zip64 file produced using the zip command with the -fd 
flag
 - Add comment to explaining the setExtraSize and readZipInputStream methods 
and the zip64File field.
 - Add comment to the call site of hasZip64 extra
 - ... and 11 more: https://git.openjdk.org/jdk/compare/ac50234c...fad0da2e

-------------

Changes:
  - all: https://git.openjdk.org/jdk/pull/12524/files
  - new: https://git.openjdk.org/jdk/pull/12524/files/01216ef7..fad0da2e

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jdk&pr=12524&range=02
 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=12524&range=01-02

  Stats: 1001872 lines in 12942 files changed: 671014 ins; 209199 del; 121659 
mod
  Patch: https://git.openjdk.org/jdk/pull/12524.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/12524/head:pull/12524

PR: https://git.openjdk.org/jdk/pull/12524

Reply via email to