Please review this PR which refactors the majority of Currency tests to use JUnit. (The leftover will be done in a separate PR).
The largest change is in `CurrencyTest.java`. To maintain the grouping of similar tests, JUnit nested classes were used. I also believe that `Bug4512215.java` should probably be merged into `CurrencyTest.java` (since they both test getCurrencyCode() and getDefaultFractionDigits(). ------------- Commit messages: - Remove trailing WS in Bug4512215.java - Rename Bug6807534.java as CurrencyNameProviderTest.java - Refactor CurrencyTest.java - Clarify CheckDataVersion.java - Refactor Bug8154295.java - Refactor Bug6807534.java - Refactor Bug4512215.java Changes: https://git.openjdk.org/jdk/pull/14682/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=14682&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8310923 Stats: 613 lines in 6 files changed: 261 ins; 184 del; 168 mod Patch: https://git.openjdk.org/jdk/pull/14682.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/14682/head:pull/14682 PR: https://git.openjdk.org/jdk/pull/14682