On Sun, 4 Jun 2023 11:28:33 GMT, Alan Bateman <al...@openjdk.org> wrote:

> Thread.sleep has had quite a bit of churn recently to support virtual 
> threads, add sleep(Duration), a JFR event, and the change the underlying 
> implementation to support sub-millis precision. I think the changes have 
> settled down now so we can do some small cleanups that came up in PR 
> discussions. The cleanups were kicked down the road as it requires tracking 
> down faraway tests that depend on the stack depth and the names of internal 
> methods. The two cleanups proposed here are:
> 
> 1.  Add a private sleepNanos method that creates/commits the JFR event around 
> the sleep, this avoids duplicate code in the 3 sleep methods.
> 2.  Rename JVM_Sleep to JVM_SleepNanos to make it clear that it takes the 
> sleep time in nanoseconds, esp. when Thread.sleep's parameter is milliseconds.

I welcome this change. We were looking at this code on Friday and was thinking 
that it would have been good to rename sleep0 and JVM_Sleep. :)

-------------

Marked as reviewed by stefank (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/14303#pullrequestreview-1461982066

Reply via email to