On Tue, 20 Dec 2022 19:05:13 GMT, Bill Huang <bhu...@openjdk.org> wrote:
>> test/jdk/javax/crypto/CryptoPermissions/InconsistentEntries.java line 52: >> >>> 50: private static final String JDK_HOME = >>> System.getProperty("test.jdk"); >>> 51: private static final String TEST_SRC = >>> System.getProperty("test.src"); >>> 52: private static final Path POLICY_DIR = Paths.get(JDK_HOME, "conf", >>> "security", >> >> This doesn't looks like a safe Test to be automated. Can it create conflict >> with any other existing Test requiring "testlimited" with >> default_local.policy? This need to be verified. Also changing anything >> inside an installed JDK probably not a good choice. It's just a thought from >> my side and it could be different for others. > > Good points. I searched the entire repo and this is the only instance that > uses the "testlimited" with default_local.policy. Looking over the logic, the > test sets the crypto.policy property to "testlimited". So I am wondering if > the "testlimited" is created for test purposes. If so, are we allowed to > rename "testlimited" to be more specific, eg. "testcryptoperms"? > `Security.setProperty("crypto.policy", "testlimited");` As long as it create no conflict with other Tests at runtime.. i am fine to keep it same. ------------- PR: https://git.openjdk.org/jdk/pull/10637