On Thu, 13 Oct 2022 19:34:52 GMT, Aleksei Efimov <aefi...@openjdk.org> wrote:
>> src/java.base/share/conf/security/java.security line 1423: >> >>> 1421: # >>> 1422: # The default pattern value allows any object factory class defined >>> in the java.naming module >>> 1423: # to be specified by the reference instance, but rejects any other. >> >> Should this instead say: >>> The default pattern value allows any object factory class belonging to the >>> `com.sun.jndi.ldap` and its sub-packages of the `java.naming` module to be >>> specified by the reference instance...? > > I would prefer to keep a filter default value explanation sentences simpler > since exact default values are listed just one line after. What you have here is OK with me then. >> src/java.naming/share/classes/com/sun/naming/internal/ObjectFactoriesFilter.java >> line 59: >> >>> 57: * @return true - if the factory is allowed to be instantiated; >>> false - otherwise >>> 58: */ >>> 59: public static boolean checkGlobalFilter(Class<?> serialClass) { >> >> I think the `serialClass` param should be renamed to `factoryClass` or >> something like that, since I think the `serialClass` reference comes from >> serialization/deserialization usage. > > The name comes from `ObjectInputFilter.FilterInfo` - it's been renamed from > `factoryClass`to make it clear that the supplied lambda fills-in the > non-default `ObjectInputFilter.FilterInfo.serialClass()` method. Thank you for that clarification, Aleksei. This sounds fine to me then. ------------- PR: https://git.openjdk.org/jdk/pull/10578