Hello, I'm not sure about this, but I think doto is named after the convention that a lot of side effecting functions/macros/special forms follow : share the "do" prefix if the name implies that there will be side effects.
And indeed, if you use doto with more than one following expression, then this list of expression will generate side effects (mutating the target object, at a minimum). My 0,02€, -- Laurent 2009/3/7 Dimiter malkia Stanev <mal...@gmail.com> > > I've just started using doto, after seeing the celsius example on the > Clojure page, but It brought back memories from Pascal days - > http://csci.csusb.edu/dick/samples/pascal.syntax.html#with_statement > > It's probably nothing, but to me (with x (.Function1) (.Function2)) > seems more readable than (doto). Off course I'm already used to doto > (spend almost 10 minutes on it), and Common Lisp learned me to be okay > with any names, because once you learn it, the name is just a memo to > what the semantics are. > > But still It might be more approachable to a newbie to use "with", > rather than "doto". Then again, the whole "with-" convention is a > whole other topic. > > Just wanted to share with you! > > > > --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Clojure" group. To post to this group, send email to clojure@googlegroups.com To unsubscribe from this group, send email to clojure+unsubscr...@googlegroups.com For more options, visit this group at http://groups.google.com/group/clojure?hl=en -~----------~----~----~----~------~----~------~--~---