On Feb 15, 5:18 pm, Rich Hickey <richhic...@gmail.com> wrote: > The second option is to choose the best possible names, and deal with > some short term pain in porting and confusion. I think the best names > are: > > ;item > (first x) > > ;collection of remaining items, possibly empty > (rest x) > > ;seq on next item, or nil if none > (next x)
After reading though all the information on the new, lazier sequences, I like this option best. 'next' is a very appropriate name, as it implies an eager load of the next item in the same way that first is an eager load of the first item. It also implies iteration in a way that, say, 'second' does not, so you'd also expect 'next' to have a tail. I also like way rest is now lazier. I don't think you should compromise Clojure's design at this point, so I definitely think you should go with first/rest/next. I don't like first/more/rest, as 'more' doesn't seem the best word to describe the new function, and for the same reason I also dislike first/more/next. Finally, I agree that tail/rest is also inappropriate, as tail and rest do not mean different things. So I'm all for the optimal first/rest/next solution. - James --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Clojure" group. To post to this group, send email to clojure@googlegroups.com To unsubscribe from this group, send email to clojure+unsubscr...@googlegroups.com For more options, visit this group at http://groups.google.com/group/clojure?hl=en -~----------~----~----~----~------~----~------~--~---