Rich Hickey wrote: >.. > The second option is to choose the best possible names, and deal with > some short term pain in porting and confusion. I think the best names > are: > > ;item > (first x) > > ;collection of remaining items, possibly empty > (rest x) > > ;seq on next item, or nil if none > (next x)
(I would say "seq-on-remainder-of-collection") I really like the first/rest decomposition concept. first (if exists) is an item, and rest is the remainder-of-whatever following the first. To me next connotes another item like the first, and that may be misleading. So I do not think that next is a good name. Please allow me as an inexpert, relatively uninvolved reader to raise an emperor's new clothes type question: why is there a need for next anyway. Are there that many idioms or code internals that justify a shortcut for (seq rest)? Regards, ..jim --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Clojure" group. To post to this group, send email to clojure@googlegroups.com To unsubscribe from this group, send email to clojure+unsubscr...@googlegroups.com For more options, visit this group at http://groups.google.com/group/clojure?hl=en -~----------~----~----~----~------~----~------~--~---