simark added inline comments.
================ Comment at: clangd/ClangdLSPServer.cpp:78 {"documentHighlightProvider", true}, + {"configurationChangeProvider", true}, {"renameProvider", true}, ---------------- Nebiroth wrote: > simark wrote: > > I find `configurationChangeProvider` a bit weird. It makes it sound like > > clangd can provide configuration changes. In reality, it can accept > > configuration changes. So I think this should be named something else. > Agreed, perhaps configurationChangeManager would be more appropriate then? I'm thinking of removing it for the time being. Since it's not defined in the protocol what types of configuration changes exist (it's specific to each language server), it not very useful to simply advertise that we support configuration changes. We would need to advertise that we support compilation database changes in particular. I think this can be done later. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D39571 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits