danielmarjamaki marked 6 inline comments as done. ================ Comment at: clang-tidy/readability/MisplacedArrayIndexCheck.cpp:57 @@ +56,2 @@ +} // namespace tidy +} // namespace clang ---------------- I removed hasMacroId() and use fixit::getText(). The replacements look good now.
================ Comment at: docs/clang-tidy/checks/readability-misplaced-array-index.rst:13 @@ +12,3 @@ + void f(int *x, int y) { + y[x] = 0; + } ---------------- ok thanks same mistake I've done before. Should I start using uppercase variable names from now on? https://reviews.llvm.org/D21134 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits