shafik added inline comments.

================
Comment at: clang/lib/AST/Expr.cpp:2283
+  case SourceLocExpr::FileName: {
+    SmallString<256> Path;
+    // builtin_FILE_NAME() is a Clang-specific extension that expands to the
----------------
It looks like a copy of the code from `ExpandBuiltinMacro` since we are already 
calling `processPathForFileMacro` from that same file why not factor out this 
code? If we can avoid code duplication we should to prevent possible future 
refactors only updating one copy of the code.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D144878/new/

https://reviews.llvm.org/D144878

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to