kadircet added inline comments.

================
Comment at: clang/tools/include-mapping/cppreference_parser.py:174
-      # std::remove<> has variant algorithm.
-      "std::remove": ("algorithm"),
-  }
----------------
this is actually checking for something else (sorry for the confusing naming).

the `variant` here refers to library name mentioned in parentheses (this is 
same problem as `std::move`) on the std symbol index page 
https://en.cppreference.com/w/cpp/symbol_index (e.g. `remove<>() (algorithm)`). 
by getting rid of this we're introducing a regression, as previously 
`std::remove` wouldn't be recognized by the library, but now it'll be 
recognized and we'll keep suggesting `<cstdio>` for it.

so we should actually keep this around.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D142092/new/

https://reviews.llvm.org/D142092

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to