t.p.northover added a subscriber: t.p.northover.
t.p.northover added a comment.

I think it would be better to use a generic method so the size is minimal 
everywhere rather than making ARM a special case. Possibly move the #define 
bits from libunwind.cpp to __libunwind_config.h and use REGISTER_KIND to 
declare unw_context_t?


================
Comment at: src/CompactUnwinder.hpp:490
@@ -488,3 +489,3 @@
 
-
+#elif defined(__arm64__) || defined(__aarch64__)
 /// CompactUnwinder_arm64 uses a compact unwind info to virtually "step" (aka
----------------
`__aarch64__` is defined for iOS too, so no need for both.


http://reviews.llvm.org/D19920



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to