echristo added a comment.

In addition to the bikeshed below, I'm not a huge fan of this in general. I 
think we should assume that the libc we link is complete and thus it would just 
be named "libc.<ext>" and in a sysroot somewhere. Another option is perhaps 
looking at the rtlib option, but I'd want to see a bit of a writeup there so we 
can see what we'd be doing.

Thoughts? Other options?

Thanks!

-eric



================
Comment at: clang/include/clang/Driver/Options.td:3626
 def specs : Separate<["-", "--"], "specs">, Flags<[Unsupported]>;
+def experimental_link_llvmlibc : Flag<["-"], "experimental-link-llvmlibc">;
 def static_libgcc : Flag<["-"], "static-libgcc">;
----------------
Bikeshedding: Not a huge fan of this name. I'd rather a more general option if 
we feel the need to select libc from an option rather than a sysroot. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D97736/new/

https://reviews.llvm.org/D97736

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to