jsji accepted this revision. jsji added inline comments.
================ Comment at: clang/lib/Driver/ToolChains/CommonArgs.cpp:403 + if (T.isOSAIX()) { + unsigned major, minor, micro; + T.getOSVersion(major, minor, micro); ---------------- stevewan wrote: > jsji wrote: > > `micro` unsed. > Sorry I missed this comment. I agree that the unused `micro` is a bit ugly, > do you have a preference on how you'd like it to be improved? We don't have > an existing query for only `major` and `minor`, and creating one seems > unnecessary IMHO. If you think renaming the variable to `unused_micro` > mitigates the problem, I can do that. That's ok to me Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97823/new/ https://reviews.llvm.org/D97823 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits