dexonsmith added inline comments.

================
Comment at: clang/lib/Frontend/CompilerInvocation.cpp:822
+
 static bool ParseAnalyzerArgs(AnalyzerOptions &Opts, ArgList &Args,
                               DiagnosticsEngine &Diags) {
----------------
jansvoboda11 wrote:
> dexonsmith wrote:
> > Can you rename this `ParseAnalyzerArgsImpl` for better readability?
> I left this unchanged to keep the diff (and merge conflicts) minimal. We 
> would rename it back to `ParseAnalyzerArgs` in a few weeks anyway (when we 
> drop granular round-tripping in favor of one big round-trip).
I still have a preference for somehow varying the two names despite the minor 
churn — maybe the other one could be parseAnalyzerArgsWithRoundTrip — but it’s 
up to you (still LGTM as-is).


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D95369/new/

https://reviews.llvm.org/D95369

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to