kadircet marked 6 inline comments as done.
kadircet added inline comments.

================
Comment at: clang-tools-extra/clangd/tool/ClangdMain.cpp:722
         /* Override */ OverrideClangTidyOptions,
-        FSProvider.getFileSystem(/*CWD=*/llvm::None));
+        FSProvider.view(/*CWD=*/llvm::None));
     Opts.GetClangTidyOptions = [&](llvm::vfs::FileSystem &,
----------------
sammccall wrote:
> we need a new conventional name for these variables.
> 
> Not sure if FS works, since we may have the vfs::FileSystem in the same 
> scope. TFS?
> 
> Ultimately we should really get rid of any mention of FSProvider in the code, 
> I don't think it's a good name for anything anymore.
> Not sure if it's more/less painful to  do this in separate patches... the 
> inconsistent naming will be confusing.
Sent out D82024


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D81998/new/

https://reviews.llvm.org/D81998



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to