aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land.
LGTM! ================ Comment at: clang-tools-extra/test/clang-tidy/checkers/readability-identifier-naming-member-decl-usage.cpp:137 +} +}; // namespace CtorInits ---------------- njames93 wrote: > aaron.ballman wrote: > > I think this is one more test case to add: base class specifiers. e.g., > > ``` > > struct foo_bar {}; // Should be renamed > > > > struct Baz : foo_bar {}; // Should rename foo_bar > > ``` > That test case already exists in the readability-identifier-naming.cpp file > > ``` > class my_derived_class : public virtual my_class {}; > // CHECK-MESSAGES: :[[@LINE-1]]:7: warning: invalid case style for class > 'my_derived_class' > // CHECK-FIXES: {{^}}class CMyDerivedClass : public virtual CMyClass {};{{$}} > ``` Oh, thank you for pointing that out! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D72121/new/ https://reviews.llvm.org/D72121 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits