martong marked 4 inline comments as done.
martong added a comment.

Thanks for the review Alexei!



================
Comment at: unittests/AST/ASTImporterTest.cpp:3549
+  void TypedTest_ImportDefinitionThenPrototype() {
+    Decl *FromTU0 = getTuDecl(getDefinition(), Lang_CXX, "input0.cc");
+    Decl *FromTU1 = getTuDecl(getPrototype(), Lang_CXX, "input1.cc");
----------------
a_sidorin wrote:
> I would ask you not to use numbers when possible: these names are hard to 
> keep in mind. There can be a nice naming scheme like 
> "FromTUDef/FromTUProto/FromTUProtoDef|, I think it would be much better.
Ok. I have removed the numbers where it makes sense: where we have a proto and 
a definition. However, there are cases when we import two similar nodes (e.g. 
two prototypes) then I think the numbering is needed to identify the first and 
second node.


================
Comment at: unittests/AST/ASTImporterTest.cpp:3704
+// FIXME This does not pass, possible error with Class import.
+//ASTIMPORTER_INSTANTIATE_TYPED_TEST_CASE(RedeclChain, Class,
+                                        
//ImportDefinitionAfterImportedPrototype);
----------------
a_sidorin wrote:
> Is it possible to disable the tests instead of commenting them out?
Okay, I have changed the macro so we can disable the tests.


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57236/new/

https://reviews.llvm.org/D57236



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to