a_sidorin added a comment.

Hi Gabor,

The refactoring looks great. I have some minor comments inline.



================
Comment at: unittests/AST/ASTImporterTest.cpp:3549
+  void TypedTest_ImportDefinitionThenPrototype() {
+    Decl *FromTU0 = getTuDecl(getDefinition(), Lang_CXX, "input0.cc");
+    Decl *FromTU1 = getTuDecl(getPrototype(), Lang_CXX, "input1.cc");
----------------
I would ask you not to use numbers when possible: these names are hard to keep 
in mind. There can be a nice naming scheme like 
"FromTUDef/FromTUProto/FromTUProtoDef|, I think it would be much better.


================
Comment at: unittests/AST/ASTImporterTest.cpp:3704
+// FIXME This does not pass, possible error with Class import.
+//ASTIMPORTER_INSTANTIATE_TYPED_TEST_CASE(RedeclChain, Class,
+                                        
//ImportDefinitionAfterImportedPrototype);
----------------
Is it possible to disable the tests instead of commenting them out?


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57236/new/

https://reviews.llvm.org/D57236



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to