On Sat, 2 Nov 2024 07:51:20 GMT, Alexander Zuev <kiz...@openjdk.org> wrote:
>> make/modules/jdk.accessibility/Lib.gmk line 57: >> >>> 55: TARGETS += $(BUILD_LIBJAVAACCESSBRIDGE) >>> 56: >>> 57: >>> ############################################################################## >> >> Most of the desktop related changes are related to Assistive Technologies >> I don't think we currently provide a 32-bit windowsaccessbridge.dll in the >> 64 bit JDK, but I'd like to be sure I am not forgetting something. >> The point being windowsaccessbridge.dll is not loaded by the JDK, but by an >> AT, so traditionally we provided both 32 and 64 bit versions because we >> don't control that AT. >> >> So I would like Alex Zuev to review these changes. For whatever reason his >> git hub handle doesn't seem to be found. I think it is something like >> @azuev-java > > We built 32-bit dll in order to provide access to the accessibility > interfaces for the legacy 32-bit software that can not load the 32-bit code. > We abandoned this practice since at least Java 11 and we had no complaints > about it ever since. All the relevant accessibility software we are aware of > have 64-bit executable and only support 32-bit operating systems with the > legacy versions that are not recommended to use with modern OSes. I do not > see any problem in abandoning 32-bit code in windowsaccessbridge.dll. @azuev-java Thanks! I have one more question for you: To avoid risking breaking any compatibility, the file generated from the source code in `windowsaccessbridge` is still compiled into a file called `windowsaccessbridge-64.dll`. This is a bit unusual, and requires a quirk in the build system -- normally we assume there is a 1-to-1 relationship between the directory containing the native library source code, and the generated `.dll` file. Is this file exposed to external parties, that rely on a specific name? Or is it just used internally by the JDK, so we could rename it to `windowsaccessbridge.dll`, and just update our reference to it? ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/21744#discussion_r1827989703