Hi, On Tue, May 25, 2010 at 09:10:57PM +0200, Carl Fredrik Hammar wrote: > On Mon, May 24, 2010 at 12:08:10PM +0200, Emilio Pozuelo Monfort wrote: > > > > diff --git a/exec/hashexec.c b/exec/hashexec.c > > index 2aa3844..7a7b329 100644 > > --- a/exec/hashexec.c > > +++ b/exec/hashexec.c > > @@ -35,6 +35,7 @@ check_hashbang (struct execdata *e, > > file_t file, > > task_t oldtask, > > int flags, > > + char *filename, > > char *argv, u_int argvlen, boolean_t argv_copy, > > char *envp, u_int envplen, boolean_t envp_copy, > > mach_port_t *dtable, u_int dtablesize, boolean_t dtable_copy,
I just noticed that there is already a local variable called file_name in this function (close call!). Even if there is no conflict you should change this for clarity's sake to, say, file_name_arg or file_name_exec. (There's even a variable called name_file in there, ugh) Regards, Fredrik