I am getting complaints from CMD check about ::: which seems necessary to
use this replaceSlots facility because it is not exported.  I will look
into initialize,
which might work fine for my concern.  I cannot remember why I did not just
use direct assignment to slots, however.  Perhaps I just found the function
and
decided using it would be better.  It would be nice to export replaceSlots
if it does not contravene an important principle.

On Wed, Sep 6, 2017 at 5:23 PM, Hervé Pagès <hpa...@fredhutch.org> wrote:

> Hi,
>
> Personally I like replaceSlots() better.
>
> Not only because it's more readable but also the fact that you can use
> initialize() to update an existing object is an undocumented feature so
> I prefer to not rely on it.
>
> Also initialize() is a generic and there could be a method defined for
> the object you're trying to update that won't behave the way you expect
> (e.g. the names of its arguments won't necessarily match the names of
> the slots).
>
> Also validation can be expensive and there are many situations where
> you know that you're replacing the object slots with thiings that
> don't break the object so I like that I can call replaceSlots() with
> check=FALSE.
>
> I actually wish the methods package had something like replaceSlots().
>
> H.
>
> On 09/06/2017 01:11 PM, Michael Lawrence wrote:
>
>> No, the best practice is to just use initialize(). It used to be that
>> replaceSlots() saved some copying, but that's no longer really the
>> case. The only potential benefit is that it can skip validity checks,
>> but usually you want those.
>>
>> Michael
>>
>> On Wed, Sep 6, 2017 at 12:55 PM, Vincent Carey
>> <st...@channing.harvard.edu> wrote:
>>
>>> Is this the preferred way of adjusting content in a
>>> live object?  It is not accessible except via ":::"
>>>
>>>          [[alternative HTML version deleted]]
>>>
>>> _______________________________________________
>>> Bioc-devel@r-project.org mailing list
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__stat.et
>>> hz.ch_mailman_listinfo_bioc-2Ddevel&d=DwICAg&c=eRAMFD45gAfqt
>>> 84VtBcfhQ&r=BK7q3XeAvimeWdGbWY_wJYbW0WYiZvSXAJJKaaPhzWA&m=iX
>>> a2JnAchBDp8QpTOD4yZHTEXOMu5gjBfDOMcvQCriU&s=0Rbio7Sp7SXzPgU4
>>> xGDGkWA7V-tkgkDizVkI9JMYQ2g&e=
>>>
>>
>> _______________________________________________
>> Bioc-devel@r-project.org mailing list
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__stat.et
>> hz.ch_mailman_listinfo_bioc-2Ddevel&d=DwICAg&c=eRAMFD45gAfqt
>> 84VtBcfhQ&r=BK7q3XeAvimeWdGbWY_wJYbW0WYiZvSXAJJKaaPhzWA&m=iX
>> a2JnAchBDp8QpTOD4yZHTEXOMu5gjBfDOMcvQCriU&s=0Rbio7Sp7SXzPgU4
>> xGDGkWA7V-tkgkDizVkI9JMYQ2g&e=
>>
>>
> --
> Hervé Pagès
>
> Program in Computational Biology
> Division of Public Health Sciences
> Fred Hutchinson Cancer Research Center
> 1100 Fairview Ave. N, M1-B514
> P.O. Box 19024
> Seattle, WA 98109-1024
>
> E-mail: hpa...@fredhutch.org
> Phone:  (206) 667-5791
> Fax:    (206) 667-1319
>

        [[alternative HTML version deleted]]

_______________________________________________
Bioc-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/bioc-devel

Reply via email to