On Monday 06 October 2008 10:42:39 Kjetil Torgrim Homme wrote: > Kern Sibbald <[EMAIL PROTECTED]> writes: > > I think the best suggestion that I have seen for the name is (at > > least in the current context): > > > > Exclude Dirs Containing = .no_backup > > > > That seems to me to be a very good name. > > I agree. > > > Concerning the placement of the directive: I think it is worth > > examining if we can easily move it to the Exclude { } section. In > > that case, the directive name could be > > > > Exclude { > > Dirs Containing = .no_backup > > ... > > } > > in that case, I think it would be natural to allow: > > Include { > Dirs Containing = .please_back_me_up > }
Unfortunately, a "Dirs Containing" within an Include section is not possible. Without going into all the details, simply try to imagine an algorithm to implement -- not possible, IMO. > > of course the meaning of the directive will be the opposite (the exact > behaviour when combined with other directives is not obvious, and > would have to be worked out.) > > for now I'm in favour of just renaming the option to "Exclude Dirs > Containing". For the moment, that is what I am planning, but I am still open to more suggestions. Best regards, Kern ------------------------------------------------------------------------- This SF.Net email is sponsored by the Moblin Your Move Developer's challenge Build the coolest Linux based applications with Moblin SDK & win great prizes Grand prize is a trip for two to an Open Source event anywhere in the world http://moblin-contest.org/redirect.php?banner_id=100&url=/ _______________________________________________ Bacula-devel mailing list Bacula-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/bacula-devel