>>>>> "Bruno" == Bruno Haible <[EMAIL PROTECTED]> writes:

Bruno> You should have seen the big patsubst while it was still in one
Bruno> big line :-)

:) :)

Just a note about changequote.  Although you would certainly have
problems with the characters [ and ] themselves, there is really no
reason to use it when using patsubst.  This is a very bad (IMHO) idiom
which is spread by Autoconf itself.

Just say no to

        changequote()
        patsubst($1, [^a-z])
        changequote([, ])

but welcome

        patsubst([$1], [[^a-z]])


Bruno> Not at all. Have you observed how often you see messages like

Bruno> checking for unistd.h... yes ...  checking for
Bruno> unistd.h... (cached) yes

Bruno> in the _same_ configure run, with no pre-existing config.cache?

Err, it is not related at all.  Your example just demonstrates that
the cache was used, I see no relationship with high or low level
results.

Had it been low level, it'd be a low level result you'd see.


Bruno> Back to the main subject. Can you provide macros of the
Bruno> following kind for the next autoconf? 

Why not, but honestly I'm trying to push that thing out of the door
now, and I'm most cleaning up, not changing.  But this change was
wanted by many people, so it might be time to swallow it.  Just give
some time.

Bruno> - AC_CHECK_EVAL_BOOL(INCLUDES, BOOLEAN-CONSTANT-EXPRESSION [,
Bruno> ACTION-IF-TRUE [, ACTION-IF-FALSE]])

Nah, quit that 2.13 writing! :)

AC_CHECK_EVAL_BOOL(INCLUDES, BOOLEAN-CONSTANT-EXPRESSION,
                   [ACTION-IF-TRUE], [ACTION-IF-FALSE])

It's more readable, and even `more true' (don't know how to say this
in proper English, `more correct' I suppose).

Bruno> - AC_CHECK_EVAL_INT(INCLUDES, INT-CONSTANT-EXPRESSION,
Bruno> VARIABLE)

Sounds a good plan.

Do you think there's will be other uses than AC_CHECK_SIZEOF?

Akim

Reply via email to