On 02/02/12 10:26, Darren Hart wrote:
On 02/01/2012 11:22 PM, Martin Jansa wrote:
On Wed, Feb 01, 2012 at 02:40:05PM -0800, Joshua Lock wrote:
On 01/02/12 14:26, Darren Hart wrote:
ranpwd is used to generate random strings of various types, including
passwords, UUIDs, and MAC addresses.
Signed-off-by: Darren Hart<dvh...@linux.intel.com>
---
meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb | 23
++++++++++++++++++++
1 files changed, 23 insertions(+), 0 deletions(-)
create mode 100644 meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
diff --git a/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
b/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
new file mode 100644
index 0000000..66fcc26
--- /dev/null
+++ b/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Random password generator"
+#SECTION = "utilities"
We may as well delete this line, no?
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM =
"file://ranpwd.c;beginline=1;endline=11;md5=0e8585e19117526efedfaeb50c345d7a"
+PR = "r0"
+
+inherit autotools
+
+SRC_URI = "git://git.zytor.com/utils/ranpwd.git"
+SRCREV = "b62aab579e288715b82d5575befaa2b8ff210c2b"
What about PV? Do you really want just "git"?
There is a 1.1 and 1.2 tag in the git repository. However, some of the
MAC related features come well after 1.2 with no subsequent tag. For
this reason I left it as "git". Is there a better way to do this? Should
I call it 1.2+ or something?
The PV determined from the SRC_URI is simply git. Martin is suggesting
you might want to set it to something different in the recipe to give a
more meaningful (and useful) value i.e:
meta/recipes-connectivity/gypsy/gypsy_git.bb:PV = "0.8+git${SRCPV}"
Cheers,
Joshua
--
Joshua Lock
Yocto Project "Johannes factotum"
Intel Open Source Technology Centre
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto