Hi Stefano,
On 12/05/2021 22:30, Stefano Stabellini wrote:
On Wed, 12 May 2021, Julien Grall wrote:
+#define LPAE_SHIFT LPAE_SHIFT_GS(PAGE_SHIFT)
+#define LPAE_ENTRIES LPAE_ENTRIES_GS(PAGE_SHIFT)
+#define LPAE_ENTRY_MASK LPAE_ENTRY_MASK_GS(PAGE_SHIFT)
+#define LEVEL_SHIFT(lvl) LEVEL_SHIFT_GS(PAGE_SHIFT, lvl)
+#define LEVEL_ORDER(lvl) LEVEL_ORDER_GS(PAGE_SHIFT, lvl)
+#define LEVEL_SIZE(lvl) LEVEL_SIZE_GS(PAGE_SHIFT, lvl)
+#define LEVEL_MASK(lvl) (~(LEVEL_SIZE(lvl) - 1))
I would avoid adding these 4 macros. It would be OK if they were just
used within this file but lpae.h is a header: they could end up be used
anywhere in the xen/ code and they have a very generic name. My
suggestion would be to skip them and just do:
Those macros will be used in follow-up patches. They are pretty useful to
avoid introduce static array with the different information for each level.
Would prefix them with XEN_ be better?
Maybe. The concern I have is that there are multiple page granularities
(4kb, 16kb, etc) and multiple page sizes (4kb, 2mb, etc). If I just see
LEVEL_ORDER it is not immediately obvious what granularity and what size
we are talking about.
I am a bit puzzled with your answer. AFAIU, you are happy with the
existing macros (THIRD_*, SECOND_*) but not with the new macros.
In reality, there is no difference because THIRD_* doesn't tell you the
exact size but only "this is a level 3 mapping".
So can you clarify what you are after? IOW is it reworking the current
naming scheme?
Cheers,
--
Julien Grall