Hi Jan,

On 30/03/2020 08:38, Jan Beulich wrote:
Maybe some variation thereof:

  - hvm_cr3_to_gfn()/hvm_gfn_to_cr3(): Handle the CR3 for HVM guest
  - {pv,compat}_mfn_to_cr3()/{pv,compat}_cr3_to_mfn(): Handle the CR3 for PV 
guest
  - cr3_to_mfn()/mfn_to_cr3(): To handle the host cr3

? This is because I'd prefer to avoid host_ prefixes (albeit I'm
not entirely opposed to such), and I'd also prefer to use xen_
prefixes as they're generally ambiguous as to what aspect of "Xen"
they actually mean.

I am happy with your suggested naming. I will have a look to see how they fit in the tree and respin the series.

Cheers,

--
Julien Grall

Reply via email to