On 30/03/2020 11:37, Roger Pau Monné wrote:
On Fri, Mar 27, 2020 at 07:05:45PM +0000, Julien Grall wrote:
From: Julien Grall <[email protected]>

The function init_ioapic_mappings() is doing more than initialization
mappings. It is also initialization the number of IRQs/GSIs supported.

So rename the function to init_ioapic(). This will allow us to re-use
the name in a follow-up patch.

Signed-off-by: Julien Grall <[email protected]>

Reviewed-by: Roger Pau Monné <[email protected]>

I've got one comment/request however.

---
  xen/arch/x86/apic.c           | 2 +-
  xen/arch/x86/io_apic.c        | 2 +-
  xen/include/asm-x86/io_apic.h | 2 +-
  3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/xen/arch/x86/apic.c b/xen/arch/x86/apic.c
index cde67cd87e..c7a54cafc3 100644
--- a/xen/arch/x86/apic.c
+++ b/xen/arch/x86/apic.c
@@ -978,7 +978,7 @@ __next:
          boot_cpu_physical_apicid = get_apic_id();
      x86_cpu_to_apicid[0] = get_apic_id();
- init_ioapic_mappings();
+    init_ioapic();

I would rename this to ioapic_init instead since you are already
changing it. I usually prefer the subsystem name to be prefixed to the
action the function performs instead of the other way around.

I will do it.

Cheers,

--
Julien Grall

Reply via email to