On Tue, Mar 11, 2025 at 8:01 AM Jan Beulich <jbeul...@suse.com> wrote: > > On 11.03.2025 11:23, Sergiy Kibrik wrote: > > --- a/xen/common/Kconfig > > +++ b/xen/common/Kconfig > > @@ -92,7 +92,7 @@ config HAS_VMAP > > config MEM_ACCESS_ALWAYS_ON > > bool > > > > -config MEM_ACCESS > > +config VM_EVENT > > def_bool MEM_ACCESS_ALWAYS_ON > > prompt "Memory Access and VM events" if !MEM_ACCESS_ALWAYS_ON > > depends on HVM > > I still don't see why we would then stick to MEM_ACCESS_ALWAYS_ON as a name > for the sibling option.
I'm not opposed to renaming it but it's also not something I see much value in doing. It's not used anywhere in the code, it's purely used in the config selector to mark that on x86 the vm_event/mem_access/monitor bits are not setup to be compiled-out. Tamas