On 07.03.2025 08:05, Juergen Gross wrote: > @@ -913,7 +917,7 @@ void send_guest_vcpu_virq(struct vcpu *v, uint32_t virq) > struct domain *d; > struct evtchn *chn; > > - ASSERT(!virq_is_global(virq)); > + ASSERT(get_virq_type(virq) == VIRQ_VCPU); > > read_lock_irqsave(&v->virq_lock, flags);
To better fit with this function's name, ... > @@ -940,7 +944,7 @@ void send_guest_global_virq(struct domain *d, uint32_t > virq) > struct vcpu *v; > struct evtchn *chn; > > - ASSERT(virq_is_global(virq)); > + ASSERT(get_virq_type(virq) != VIRQ_VCPU); > > if ( unlikely(d == NULL) || unlikely(d->vcpu == NULL) ) > return; ... I think this function wants renaming to send_guest_domain_virq(), to further eliminate underlying confusion. Ideally right here, but certainly also possible in a follow-on patch. Everything else looks okay to me. Jan