On 02.10.2024 09:41, Jan Beulich wrote: > Further use the generic framework from xen/linkage.h. While there drop > excess alignment and move to .bss. > > Requested-by: Andrew Cooper <andrew.coop...@citrix.com> > Signed-off-by: Jan Beulich <jbeul...@suse.com>
May I please ask for an ack or otherwise? Jan > --- > Of course alongside ASM_INT() we could introduce ASM_QUAD() and > ASM_QUAD_LOCAL() (only the latter needed right here) to aid readability. > Thoughts? > > --- a/xen/arch/x86/acpi/wakeup_prot.S > +++ b/xen/arch/x86/acpi/wakeup_prot.S > @@ -1,3 +1,5 @@ > +#define DATA_FILL 0 /* For the .bss contributions at the bottom. */ > + > #include <asm/asm_defns.h> > #include <asm/msr-index.h> > #include <asm/page.h> > @@ -134,13 +136,20 @@ LABEL(s3_resume) > ret > END(do_suspend_lowlevel) > > -.data > - .align 16 > + .bss > > -saved_rsp: .quad 0 > -saved_cr0: .quad 0 > +DATA_LOCAL(saved_rsp, 8) > + .quad 0 > +END(saved_rsp) > +DATA_LOCAL(saved_cr0, 8) > + .quad 0 > +END(saved_cr0) > #ifdef CONFIG_XEN_SHSTK > -saved_ssp: .quad 0 > +DATA_LOCAL(saved_ssp, 8) > + .quad 0 > +END(saved_ssp) > #endif > > + .data > + > ASM_INT(saved_magic, 0x9abcdef0)