On 23.05.2024 16:37, Roger Pau Monné wrote: > On Wed, May 08, 2024 at 01:39:21PM +0100, Alejandro Vallejo wrote: >> --- a/xen/arch/x86/include/asm/hvm/hvm.h >> +++ b/xen/arch/x86/include/asm/hvm/hvm.h >> @@ -798,6 +798,12 @@ static inline void hvm_update_vlapic_mode(struct vcpu >> *v) >> alternative_vcall(hvm_funcs.update_vlapic_mode, v); >> } >> >> +static inline void hvm_vlapic_sync_pir_to_irr(struct vcpu *v) >> +{ >> + if ( hvm_funcs.sync_pir_to_irr ) >> + alternative_vcall(hvm_funcs.sync_pir_to_irr, v); > > Nit: for consistency the wrappers are usually named hvm_<hook_name>, > so in this case it would be hvm_sync_pir_to_irr(), or the hvm_funcs > field should be renamed to vlapic_sync_pir_to_irr.
Funny you should mention that: See my earlier comment as well as what was committed. Jan