On 29.11.2023 16:18, Stewart Hildebrand wrote: > On 11/29/23 06:03, Roger Pau Monné wrote: >> On Tue, Nov 28, 2023 at 02:44:24PM -0500, Stewart Hildebrand wrote: >>> @@ -407,26 +445,26 @@ uint32_t vpci_read(pci_sbdf_t sbdf, unsigned int reg, >>> unsigned int size) >>> >>> /* >>> * Perform a maybe partial write to a register. >>> - * >>> - * Note that this will only work for simple registers, if Xen needs to >>> - * trap accesses to rw1c registers (like the status PCI header register) >>> - * the logic in vpci_write will have to be expanded in order to correctly >>> - * deal with them. >>> */ >>> static void vpci_write_helper(const struct pci_dev *pdev, >>> const struct vpci_register *r, unsigned int >>> size, >>> unsigned int offset, uint32_t data) >>> { >>> + uint32_t val = 0; >> >> Nit: might be clearer to name this 'current': it's easy to get >> confused whether val or data holds the user-provided input. > > The name 'current' shadows an existing global variable/macro. How about > current_val?
Or curval? Or just cur (to not collide with our common use of curr)? Jan