On 05/24/2018 01:53 AM, Jan Beulich wrote:
On 24.05.18 at 02:46, <sameer.g...@linaro.org> wrote:
Port WARN_ON_ONCE macro from Linux.
In such a case you should justify adjustments you've made:
I can add more details, but have mostly just changed variable names. The macro is self explanatory.

Should I just change this to: "Define WARN_ON_ONCE macro to mirror LInux functionality"

--- a/xen/include/xen/lib.h
+++ b/xen/include/xen/lib.h
@@ -11,6 +11,19 @@
  #define BUG_ON(p)  do { if (unlikely(p)) BUG();  } while (0)
  #define WARN_ON(p) do { if (unlikely(p)) WARN(); } while (0)
+#define WARN_ON_ONCE(p) \
+({                                                    \
+    static bool __section(".data.unlikely") warned;   \
Linux uses .data.once. That or .data.cold would seem better to me than
.data.unlikely.
I guess there is not reason to keep this in a specific section. I'll just go ahead and remove the section here?


Jan




_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

Reply via email to