Hi, Title:
Please add "xen/arm: " to clarify this is a patch touching the Arm code. On 21/07/2023 16:37, Federico Serafini wrote:
Change parameter name from 'ptr' to 'v' in the function definition thus addressing violations of MISRA C:2012 Rule 8.3: "All declarations of an object or function shall use the same names and type qualifiers".
The parameters are consistent between arm32 and arm64. Naming wise, any reason you picked the x86 name? Personally, I have a slight preference to keep 'ptr' because this is more obvious than 'v'.
But I will not strongly argue against it. That said, if you are looking for consistency, you should also modify arm32.
Cheers, -- Julien Grall
