Hi,
在 2022/3/6 03:42, Greg Kroah-Hartman 写道:
On Sat, Mar 05, 2022 at 11:33:58PM +0800, zhanglianjie wrote:
Hi,
在 2022/3/5 21:55, Greg Kroah-Hartman 写道:
On Sat, Mar 05, 2022 at 09:38:23PM +0800, zhanglianjie wrote:
Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more clear.
Minor readability improvement.
Signed-off-by: zhanglianjie <zhanglian...@uniontech.com>
Is this the name you sign legal documents with? (I have to ask...)
Yes, this is my signature.
diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c
index feb1d16252e7..fcb0792f090e 100644
--- a/drivers/xen/sys-hypervisor.c
+++ b/drivers/xen/sys-hypervisor.c
@@ -22,11 +22,10 @@
#endif
#define HYPERVISOR_ATTR_RO(_name) \
-static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name)
+static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name)
Why change this line? That's not relevant to this change :(
There are two spaces between struct hyp_sysfs_attr and _name, by the way,
modify it.
Coding style cleanups should be a separate patch, as each change should
only do one logical thing.
But hey, I'm not the maintainer of this file/driver, others might be
more lax.
Thanks for the guide, I will pay attention to these in the future.
good luck!
greg k-h