On 22/02/2022 13:30, Michal Orzel wrote:
Hi Julien,
Hi Michal,
On 21.02.2022 11:22, Julien Grall wrote:
From: Julien Grall <jgr...@amazon.com>
Commit 05031fa87357 "xen/arm: guest_walk: Only generate necessary
offsets/masks" introduced LPAE_ENTRIES_MASK_GS. In a follow-up patch,
we will use it for to define LPAE_ENTRY_MASK.
for is unneddded. Should be "we will use it to define..."
I fixed this one and ...
This will lead to inconsistent naming. As LPAE_ENTRY_MASK is used in
many places, it is better to rename LPAE_ENTRIES_MASK_GS and avoid
some churn.
So rename LPAE_ENTRIES_MASK_GS to LPAE_ENTRY_MASK_GS.
Signed-off-by: Julien Grall <jgr...@amazon.com>
---
Changes in v2:
- New patch
---
xen/arch/arm/include/asm/lpae.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/xen/arch/arm/include/asm/lpae.h b/xen/arch/arm/include/asm/lpae.h
index e94de2e7d8e8..4fb9a40a4ca9 100644
--- a/xen/arch/arm/include/asm/lpae.h
+++ b/xen/arch/arm/include/asm/lpae.h
@@ -180,7 +180,7 @@ static inline bool lpae_is_superpage(lpae_t pte, unsigned
int level)
*/
#define LPAE_SHIFT_GS(gs) ((gs) - 3)
#define LPAE_ENTRIES_GS(gs) (_AC(1, U) << LPAE_SHIFT_GS(gs))
-#define LPAE_ENTRIES_MASK_GS(gs) (LPAE_ENTRIES_GS(gs) - 1)
+#define LPAE_ENTRY_MASK_GS(gs) (LPAE_ENTRIES_GS(gs) - 1)
Incorrect indentation of (LPAE_ENTRIES_GS(gs) - 1)
... this one in my tree. I will commit it with Bertrand's reviewed-by.
Thank you for the review!
Cheers,
--
Julien Grall